Упражнения по теме «Логические функции MS Excel»

Логические функции:

 
 

=ЕСЛИ(УСЛОВИЕ; ВЫРАЖЕНИЕ1; ВЫРАЖЕНИЕ2)

Рис. 1

=ЕСЛИ(И (УСЛОВИЕ1;УСЛОВИЕ2);ВЫРАЖЕНИЕ1;ВЫРАЖЕНИЕ2)

=ЕСЛИ(ИЛИ (УСЛОВИЕ1;УСЛОВИЕ2);ВЫРАЖЕНИЕ1;ВЫРАЖЕНИЕ2)

=ЕСЛИ(УСЛОВИЕ1;ВЫРАЖЕНИЕ1;ЕСЛИ(УСЛОВИЕ2;ВЫРАЖЕНИЕ2;ВЫРАЖЕНИЕ3))

 
 

Рис. 2

Постановка задачи

Торговый склад производит уценку хранящейся продукции. Если продукция хранится на складе дольше 10 месяцев, то она уценивается в 2 раза, а если срок хранения превышает 6 месяцев, но не достигает 10 месяцев, то в 1,5 раза. Получить ведомость уценки товара, которая должна включать следующую информацию: наименование товара, срок хранения, цена товара до уценки, цена товара после уценки и информационное поле «Товар уценен/не уценен».

Решение

1. Открыть файл Уценка.xls.

2. В ячейку D2 вызываем функцию ЕСЛИ (лента Формулы – группа Библиотека функций – категория Логические). Заполняем аргументы функции:

· Лог_выражение - вводим составное условие на срок хранения И(В2>=6;B2<10) (если срок хранения больше шести месяцев, но не превышает 10-и месяцев),

· Значение_если_истина – вводим выражение С2/1,5, которое необходимо вычислить, если условие выполняется (если срок хранения больше шести месяцев, но не превышает 10-и месяцев, то цена уменьшается в полтора раза),

· Значение_если_ложь – выполняем вставку новой ЕСЛИ, т.к. осталось еще два варианта назначения цены: цена остается прежней или уменьшается в два раза. Для вставки новой ЕСЛИ достаточно кликнуть по имени функции ЕСЛИ в списке 10-ти последних функций (рис. 3).

Рис. 3

В новом диалоге ЕСЛИ заполняем аргументы по образцу:

· Лог_выражение - вводим условие на срок хранения В2>=10 (если срок хранения больше 10-и месяцев),

· Значение_если_истина – вводим выражение С2/2, которое необходимо вычислить, если условие выполняется (если срок хранения больше 10-и месяцев, то цена уменьшается в два раза),

· Значение_если_ложь – вводим выражение С2, которое необходимо вычислить, если условие не выполняется (если срок хранения не больше 10-и месяцев и меньше шести месяцев, то цена остается прежней) (рис. 4).

 

Рис. 4

3. Копируем формулу до ячейки D12.

4. В ячейку Е2 вызываем функцию ЕСЛИ. Заполняем аргументы функции:

· Лог_выражение - вводим условие на изменение цены D2<C2 (если цена после уценки меньше, чем цена до уценки),

· Значение_если_истина – вводим текст «Товар уценен», который необходимо вывести, если условие выполняется (если цена после уценки меньше, чем цена до уценки, то товар уценен),

· Значение_если_ложь – вводим текст «Товар не уценен», который необходимо вывести, если условие не выполняется (если цена осталась прежней, то товар не уценен) (рис. 5).

Рис. 5

5. Копируем формулу до ячейки Е12.


 

Задания для самостоятельного выполнения:

Средствами Microsoft Excel оформить таблицу. Назначить для ячеек необходимый формат. Вычислить требуемые.

1 вариант.

1. Перейти на лист Цемент.

2. Вычислить значения ячеек столбца “Сумма, руб.”, если при приобретении более 1 т цемента предоставляется скидка 5%, а более 10 т – скидка составит 20%.

3. С помощью инструмента Промежуточные итоги определить количество проданного цемента каждой марки. Построить диаграмму, отражающую количество приобретенного цемента каждой марки.

4. Вычислить Итого по полю «Сумма, руб.».

5. Вычислить среднюю стоимость 1 т. цемента с помощью функции СРЗНАЧ.

 

2 вариант.

1. Перейти на лист Сделки.

2. Вычислить объем страховых сделок за III кв. как сумму столбцов “июль”, “август”, “сентябрь”.

3. Вычислить комиссионное вознаграждение в расчете 5% от суммы сделок за III кв. при сумме сделок от 700 до 900 у.е. и 8% от суммы сделок за III кв. при сумме сделок выше 900 у.е. Если сумма сделок ниже 700 у.е, то вознаграждение начисляется в размере 1%.

4. С помощью инструмента Промежуточные итоги определить суммарный объем сделок за III квартал по каждому менеджеру. Построить диаграмму, отражающую объем сделок за III квартал по каждому менеджеру.

5. Вычислить по полям “июль”, “август”, “сентябрь” и III_квартал Всего, средний, максимальный и минимальный объем сделок (СУММ, СРЗНАЧ, МАКС, МИН).

 

3 вариант

1. Перейти на лист Осадки.

2. Вычислить значения объема осадков в мм по полям “Всего”, “Максимум”, “Минимум”, “Среднее” (СУММ, МАКС, МИН, СРЗНАЧ).

3. В столбце “Характер зимы” вывести слово “обычная”, если количество осадков находится в диапазоне между 50 и 100 мм., иначе выводить слова “нет снега”, если количество осадков меньше 50 мм, и слово “снежная”, если количество осадков больше 100 мм.

4. С помощью инструмента Промежуточные итоги определить суммарный объем осадков по каждому типу зимы. Построить диаграмму, отражающую объем осадков по каждому типу зимы.

5. Вычислить по полям “февраль”, “январь”, “декабрь” средний, максимальный и минимальный объем осадков (СРЗНАЧ, МАКС, МИН).





©2015-2017 poisk-ru.ru
Все права принадлежать их авторам. Данный сайт не претендует на авторства, а предоставляет бесплатное использование.

Обратная связь

ТОП 5 активных страниц!