ПРИМЕНЕНИЕ НЕПАРАМЕТРИЧЕСКИХ КРИТЕРИЕВ ДЛЯ АНАЛИЗА ДАННЫХ




Занятие № 4

 

Пример 1. В цехе с 10 станками ежедневно регистрировалось число вышедших из строя станков. Всего было проведено 200 наблюдений, результаты приведены в таблице:

Число выбывших станков
Число случаев

Проверить гипотезу о том, что число выбывших из строя станков имеет распределение Пуассона. Принять α = 0,05.

Последовательность выполнения

Закон распределения Пуассона имеет вид:

,

где: n - число испытаний; k - число появления события А в n испытаниях; l=np, p - вероятность появления события А в одном испытании.

Ввести в диапазон А2:А12 число станков, а в диапазон В2:В12 - число случаев.

В ячейке В13 рассчитать число случаев. Для этого в ячейку ввести формулу: =СУММ(В2:В12). Получим результат: 200.

В ячейке В14 рассчитать общее число отказов по формуле: =СУММПРОИЗВ(А2:А12; В2:В12). Получим результат: 360.

В ячейке В15 рассчитать значение параметра по формуле: =B14/B13.

Для расчёта теоретических частот введём следующие формулы:

В ячейку С2: =ПУАССОН(A2;$B$15;ИСТИНА)*$B$13

В ячейку С3:

=(ПУАССОН(A3;$B$15;ИСТИНА)-ПУАССОН(A2;$B$15;ИСТИНА))*$B$13

Протянуть формулу из ячейки С3 до ячейки С12. В диапазоне С2:С12 получим значения теоретических частот.

 

 

Так как частоты в ячейках C8:C12 меньше 5, то их следует объединить с ячейкой С7.

В диапазонах D2:D7 и E2:E7 получить окончательное распределение частот.

В диапазоне F2:F7 вычислить квадраты наблюдаемых частот по формуле: =D2:D7^2.

В диапазоне G2:G7 вычислить квадраты наблюдаемых частот по формуле: =F2:F7/E2.

В ячейке G9 найти сумму по формуле =СУММ(G2:G7).

Наблюдаемое значение критерия вычислить в ячейке G10 по формуле: = G9-В13. Получим результат: 12,94.

Для расчёта критического значения критерия хи-квадрат воспользуемся функцией ХИ2ОБР(вероятность; степени_свободы). В качестве вероятности зададим уровень значимости 0,05, а число степеней свободы будет равно 4 (6-1-1).

В ячейку G11 ввести формулу:

= ХИ2ОБР(0,05;4). Получим результат: 9,488.

Так как > (12,94>9,488), то гипотезу о том, что число выбывших из строя станков имеет распределение Пуассона, следует отклонить.

 

Пример 2. Был измерен вес (в кг) у 55 обезьян-павианов. По выборке был построен интервальный статистический ряд. Проверить гипотезу о нормальном распределении генеральной совокупности, приняв уровень значимости α = 0,1.

Номер интервала, k Границы интервала Наблюдаемая частота, mi
10 - 12
12 - 14
14 - 16
16 - 18
18 - 20
20 - 22
22 - 24

 

Последовательность выполнения

Ввести исходные данные в диапазон A2:C8. В диапазоне D2:D8 рассчитать середины интервалов по формуле =(B2+C2)/2, которую затем протянуть до D8.

В ячейки E2:E8 ввести наблюдаемые частоты.

В ячейку E9 ввести объём выборки n = 55.

В ячейке В10рассчитать среднее выборки по формуле

=СУММПРОИЗВ(D2:D8;E2:E8)/$E$9.

В ячейке В11рассчитать выборочную дисперсию по формуле:

=СУММПРОИЗВ(D2:D8;D2:D8;E2:E8)/$E$9-B10^2.

В ячейке В12рассчитать выборочное стандартное отклонение: =КОРЕНЬ(В11).

Для расчёта теоретических частот в ячейку F2 формулу:

=(НОРМРАСП(C2;$B$10;$B$12;ИСТИНА)-НОРМРАСП(B2;$B$10;$B$12;ИСТИНА))*$E$9,

которую затем протянем до ячейки F8.

Так как для первого интервала левая граница принимается равной - ∞, то исправим формулу в ячейке F2:

=(НОРМРАСП(C2;$B$10;$B$12;ИСТИНА)-0)*$E$9.

Так как для последнего интервала правая граница принимается равной + ∞, то исправим формулу в ячейке F8:

=(1-НОРМРАСП(B8;$B$10;$B$12;ИСТИНА))*$E$9.

 

Объединим частоты для первого и второго интервалов, а также для шестого и седьмого интервалов.

В ячейке I11рассчитаем значение критерия хи-квадрат: 1,11.

Найдём критическое значение критерия для α = 0,1 и числа степеней свободы 5-2-1=2 с использованием функции:

= ХИ2ОБР(0,1;2). Получим результат: 4,61.

Так как < (1,11<4,61), то гипотезу о том, что вес обезьян подчиняется нормальному закону, следует принять.

 

Пример 3. Две группы выпускников двух высших учебных заведений (1 и 2) (в первой группе 9 человек, во второй -10), получили оценки своих административных способностей в баллах.

1 вуз: 26; 23; 19; 21; 14; 18; 29; 17; 12.

2 вуз: 16; 10; 8; 3; 24; 20; 7; 15; 9; 22.

С помощью критерия Манна-Уитни при уровне значимости a £ 0,025 проверить нулевую гипотезу о том, группа выпускников первого вуза не превосходит группу выпускников второго вуза по уровню административных способностей.

Последовательность выполнения

Сформулируем гипотезы:

H0: Группа выпускников первого вуза не превосходит группу выпускников второго вуза по уровню административных способностей (т.е. различия незначимы).

H1: группа выпускников первого вуза превосходит группу выпускников второго вуза по уровню административных способностей. (В данном случае H1 является направленной).

Введём исходные данные в ячейки A2:A10 (показатели выпускников 1 вуза) и в ячейки B2:B11 (показатели выпускников 2 вуза).

В ячейках C2:C20составим объединенную выборку и выпоним ранжирование. Для этого в ячейку D2 введём формулу =РАНГ(C2,$C$2: $C$20;1) и протянем её до ячейки D20.

В ячейки F7 и F8 введём объемы выборок, а в ячейку F9 - объём объединённой выборки.

В ячейках F10и F11рассчитаем суммы рангов элементов каждой из выборок по формулам:

=СУММ(D2:D10) и =СУММ(D11:D20).

Получим результаты: 112 и 78.

Выполним проверку правильности ранжирования, вычислив общую сумму рангов, и сравним её с суммой рангов, найденной по формуле:

.

В ячейку F13введём формулу =F10+F11. Получим результат: 190. В ячейку F14введём формулу =F9*(F9+1)/2. Получим результат: 190. Следовательно, ранги приписаны правильно.

Находим большую из двух ранговых сумм = 112 (соответствует первой выборке n1 = 9), т. е. nx = 9. Запишем эти значения в ячейки F15и F16.

 

Находим наблюдаемое значение критерия. В ячейкуF17введём формулу =F7*F8+F15*(F15+1)/2-F16. Получим результат: 23.

Находим критическое значение критерия. По таблице определяем критическое значение в случае направленной альтернативы, причем меньшее n принимаем за n1 (n1 =9), а большее за n2 (n2 =10). =23 для a £ 0,025.

Вывод: так как £ , то H0 отвергается и принимается гипотеза H1.

...





Читайте также:
Группы красителей для волос: В индустрии красоты колористами все красители для волос принято разделять на четыре группы...
Ограждение места работ сигналами на перегонах и станциях: Приступать к работам разрешается только после того, когда...
Средневековье: основные этапы и закономерности развития: Эпоху Античности в Европе сменяет Средневековье. С чем связано...
Экономика как подсистема общества: Может ли общество развиваться без экономики? Как побороть бедность и добиться...

Поиск по сайту

©2015-2022 poisk-ru.ru
Все права принадлежать их авторам. Данный сайт не претендует на авторства, а предоставляет бесплатное использование.
Дата создания страницы: 2019-04-04 Нарушение авторских прав и Нарушение персональных данных


Поиск по сайту:


Мы поможем в написании ваших работ!
Обратная связь
0.018 с.